When you’re creating a project with
Dynamic Web Module 3.0 support, you should be using Java 1.6 or newer. I’ll be fixing this issue with Java 1.7, using Eclipse.
The “Markers” tab will be showing the next error:
First check that your project is configured probably to use Java 1.7.
Right click your project > Properties > Java Compiler and set “Compiler compliance level” to 1.7.
Next from the menu on the left select Project Facets > Java and set its version to 1.7
If you didn’t find 1.7 as one of the drop down options in the previous preferences, then you have to add it to eclipse first.
Navigate to eclipse Preferences > Java > Installed JREs, click Add, and locate your installed Java path.
Open your project’s
pom.xml and add this plugin tag
<build> <plugins> <plugin> <groupId>org.apache.maven.plugins</groupId> <artifactId>maven-compiler-plugin</artifactId> <version>3.1</version> <configuration> <source>1.7</source> <target>1.7</target> </configuration> </plugin> </plugins> </build>
Finally, right click on your project > Maven > Update Project…
This solution was tested using:
Maven v3.1 and
Eclipse Kepler on Mac OSX Lion.